Ubuntu 18.04 Bionic Beaver armhf MongoDB packages (updated to mongodb 3.2.21)

New mongodb 3.2.x version (3.2.21) was recently released, and I’ve built new packages for ubuntu 18.04.

Also I’ve spotted that previous packages of version 3.2.20 have some annoying behaviour, meaning mongodb server starts to occupy cpu 100% after some time doing useless “usleep” loops (pretty much doing nothing waking up several times a second to do nothing again).

I don’t know with what this is related, but this time to build packages I’ve gathered all the knowledge around the internet how to do that additionally to my researches. There are few more tricks included building those packages now including some armhf specific compiler and linker options and I don’t see that strange behaviour anymore. If you had problems with packages from the previous post, – upgrade. If you just stumbled upon this post – install 3.2.21, it is better.

mongodb-clients_3.2.21-0ubuntu1_armhf
mongodb-server-core_3.2.21-0ubuntu1_armhf
mongodb-server_3.2.21-0ubuntu1_all
mongodb_3.2.21-0ubuntu1_armhf

9 thoughts on “Ubuntu 18.04 Bionic Beaver armhf MongoDB packages (updated to mongodb 3.2.21)”

  1. Thank you! This saved my day and was the last piece of the puzzle moving towards web development done on an Odroid XU4. Now I can happily code away on solar power 🙂

  2. i am on odroid xu4, 18.04.2 LTS…

    seems there are a bunch of dependencies that will no longer install…

    Unpacking mongodb-clients (1:3.2.21-0ubuntu2) over (1:3.2.21-0ubuntu2) …
    dpkg: dependency problems prevent configuration of mongodb-clients:
    mongodb-clients depends on libboost-chrono1.67.0; however:
    Package libboost-chrono1.67.0 is not installed.
    mongodb-clients depends on libboost-filesystem1.67.0; however:
    Package libboost-filesystem1.67.0 is not installed.
    mongodb-clients depends on libboost-program-options1.67.0; however:
    Package libboost-program-options1.67.0 is not installed.
    mongodb-clients depends on libboost-regex1.67.0; however:
    Package libboost-regex1.67.0 is not installed.
    mongodb-clients depends on libboost-system1.67.0; however:
    Package libboost-system1.67.0 is not installed.
    mongodb-clients depends on libboost-thread1.67.0; however:
    Package libboost-thread1.67.0 is not installed.
    mongodb-clients depends on libc6 (>= 2.28); however:
    Version of libc6:armhf on system is 2.27-3ubuntu1.
    mongodb-clients depends on libyaml-cpp0.5v5; however:
    Package libyaml-cpp0.5v5 is not installed.

    1. Thank you for reporting, I’ll have a look into that beginning of June. I’m away from my building bench yet.

    2. I took a look into the issue, and it seems to be coming from the thing that dpkg doesn’t install dependancies automatically as apt does. So basically doing “apt –fix-broken install” after the command before is going to pick up all the mentioned missing dependencies and install them to the system after which all the mongo packages installs fine.

  3. Amazing!

    I lost access to the host compute of my previous Unifi controller and decided to reinstall OS. I’m using a Raspberry Pi 2 (early gen) and Ubuntu Core for 32-bit ARM device. From all that I read MongoDB has abandoned 32-bit armhf architecture. With your packages I was able to successfully run Ubuntu 18.04 on my device and run the fully updated Unifi Controller.

Leave a Reply to Tux Solbakk Cancel reply

Your email address will not be published. Required fields are marked *